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 2 WARNINGS AND CAUTIONS 
All warnings and cautions listed throughout this manual are to be observed when operating the 
device.   

WARNING: Indicates a potentially hazardous situation which, if not avoided, could cause injury 
or harm to the patient or erroneous results. 

CAUTION: Indicates a potentially hazardous situation which, if not avoided, may result in minor 
injury or harm to the equipment. 

 

 GENERAL WARNINGS 

WARNING: Using non-essential software in conjunction with the system could have unknown/
adverse impact on the operation of the device and is therefore not recommended. 

WARNING: Due to the threat of computer viruses, it is recommended that an anti-virus program 
be installed on the computer running the Scanmate application and that patient records be 
backed up regularly.  

WARNING: Electromagnetic interference may cause distortion of received ultrasonic signals. 
Such interference may result in distorted images or waveforms. 

WARNING: Use of this equipment adjacent to or stacked with other equipment may result in 
improper operation and should be avoided. If such use is necessary, all equipment should be 
observed to verify normal operation. 

WARNING: Portable RF communications equipment (including peripherals such as antenna 
cables and external antennas) should be used no closer than 30 cm (12 inches) to any part of the 
device, including cables specified by the manufacturer. Otherwise, degradation of the 
performance of this equipment could result. 

WARNING: Use of accessories, transducers and cables other than those specified or provided by 
the manufacturer of this equipment could result in increased electromagnetic emissions or 
decreased electromagnetic immunity of this equipment and result in improper operation. 

WARNING: Improper backup/restoration of the Scanmate database could result in lost/

corrupted data. 

WARNING: PCs connected to DGH devices must be isolated from ground using a medical grade 
power supply . 
 

 

 GENERAL CAUTIONS 

CAUTION: Disconnect the device from the host computer before performing routine 
maintenance or cleaning. Always follow the manufacturer’s instructions when cleaning and 
disinfecting probes. 

CAUTION: Changing network configuration and/or network devices may have an unknown/
adverse impact on connection of the Scanmate application to a remotely hosted database. 



 

 3 SYSTEM REQUIREMENTS 

 Minimum Recommended 
Processor: 2.0 GHz  3.0+ GHz  
Architecture: 32-bit or 64-bit 64-bit  
Memory: 2 GB RAM 4 GB RAM 
Hard Drive: HDD or SSD  SSD 
Storage Space: 1 GB  250 GB 
Display: 1024 x 768 resolutionA 
Peripherals: Mouse/Touchpad, Keyboard 
Ports: (2x) USB 2.0B   
PC Power Supply: AC/DC Medical Grade TransformerC 
 
Compatible OS: Microsoft Windows 7  (32-bit / 64-bit) 
 Microsoft Windows 8/8.1  (32-bit / 64-bit) 
 Microsoft Windows 10  (32-bit / 64-bit) 
 Microsoft Windows Server 2008 R2D (64-bit) 
 Microsoft Windows Server 2012 / 2012 R2D  (64-bit) 
 Microsoft Windows Server 2016D  (64-bit) 
 
A  The software can be operated using touch controls on systems that have a touch-capable 

 display. Buttons, sliders and combo boxes can be operated by touching the screen. Refer to the 

 device’s operating manual for more information. 

B  1 port used for USB interface, 1 port used for footswitch. 
 

WARNING: PCs connected to DGH devices must be isolated from ground using a medical 
grade power supply . 

 

D  Server Operating Systems only support installation of the SQL Server database. Refer to 
 Installation Guide for more information. 

 

 

READ BEFORE INSTALLING 
If the Scanmate software is to be used with a networked database, all networked computers 
that will be used with the Scanmate software  must utilize the same domain. It is also necessary 
to verify that network firewall settings do not interfere with the computer connection. 
 
It is essential that the system hosting the SQL Server database DOES NOT have a Windows login 
user name that matches the computer name. If this is the case, a SQL Server installation error 
will occur. 
 
Before beginning installation, verify that you have full administrator access to the computer. Full 
administrator access is necessary for installation of the database server. 

 
Installation prerequisites may be downloaded from internet repositories. An internet connection 
is required during installation. 

C 



 

 4 WORKSTATION CONFIGURATION OPTIONS 
Please consider the desired use of the Scanmate software before installation.  Patient data may 
be saved on the computer operating the device or on a server. Deciding how a system shall be 
used will determine which software components must be installed. 
 
Single PC Workstation:  When a single computer will be used to operate the device (no 
connection to a remote database) the Single PC option may be used. This option installs the DGH 
Scanmate software and Scanmate database on the same PC.  A single PC workstation can be 
connected to either a SQL Server or SQLite database.  

 

ATTENTION: It is suggested that a SQL Server database be used if storing large video files or 
many patients records. A SQLite database is only suggested if storing few files (i.e. videos/
images/reports are exported and then imported into an electronic medical records system).  

ATTENTION: The only PC that can access a SQLite database is the PC that is storing the SQLite 
database. The SQLite database cannot be made available on a network. 

ATTENTION: It is not suggested to use a SQLite database when saving large video files. 

 

 

 

 

 

 

Database Server with Networked Workstations: The DGH Scanmate software may be 
networked so that one or more workstation computers connect to a SQL Server database that is 
stored on a local server. Workstation computers operate the devices and transfer patient data 
to/from the database. If this is the desired installation, first install the database on the server by 
selecting the Server PC option. Next install the Scanmate software on each workstation by 
selecting the Client PC option.  

ATTENTION: All Server and Client PCs must be utilizing the same Windows Domain Network in 
order for the Client PCs to connect to the database. 
 

 
Windows Domain Network 

Server PC 

1ST 

Client PC 

2ND 

Client PC 

2ND 

Single PC 



 

 5 BEGINNING INSTALLATION 
Insert the installation media that contains the Scanmate installation files and launch the installer 
application. 

If the device will be used in a networked configuration, SQL Server should be installed on a the  
server prior to installation of the DGH Scanmate software on workstation PCs.  
 
ATTENTION: All Server and Client PCs must be utilizing the same Windows Domain Network in 
order for the Client PCs to connect to the database. 
 

ATTENTION: Installation prerequisites may be downloaded from internet repositories. An 
internet connection is required during installation. 

 
 

PREREQUISITE INSTALLATION 
The installer program will perform a search for 
necessary prerequisites. A message will appear if 
a prerequisite is missing from the system. Click 
[NEXT] to continue the installer, the installer will 
show a prompt indicating which prerequisites 
must be installed.  Prerequisites will be marked  
for installation by default. Click [NEXT] to 
continue the installer.  
 
 
A progress bar will display the installation status 
of the prerequisites. When prerequisite 
installation is complete, the installer will advance 
to the next screen. 
 
 
 
 
 
 
 

TERMS AND CONDITIONS 
When starting the Scanmate Installer, the terms 
and conditions must be accepted. Review the End 
User License Agreement (EULA) by clicking on the 
“License terms and conditions” link. 
 
Mark the checkbox next to “I agree to the License 
terms and conditions”. Click [NEXT] to continue 
the installer.   
 
 
 



 

 6 SINGLE PC 

This option installs both the DGH Scanmate 
software and DGH Scanmate database on a PC. 
 
Select the Single PC installation option., then 
select either the SQLite or SQL Server radio 
button. Click [NEXT] to continue. 
 
 
IF installing SQLite, proceed to Page 7 for Single PC Installation: SQLite Database information. 
 

IF installing SQL Server, proceed to Page 8 for Single PC Installation: SQL Server Database 
information. 
 
Note: Refer to Page 4 for information regarding SQLite and SQL Server databases. 
 

SERVER PC 
This option installs the SQL Server 2012 database 
program. This installation should be performed 
prior to running the Client PC installer. 
 
Select the Server PC installation option and click 
[NEXT] to continue. 
 
Proceed to Page 9 for Server PC Installation information. 
 

CLIENT PC 
This option installs the DGH Scanmate software, 
which will be connected to a database on a 
network. This installation should be performed 
after running the Server PC installer. 
 
Select the Client PC installation option and click 
[NEXT] to continue. 
 
Proceed to Page 10 for Client PC Installation information. 
 

UPDATING DGH SCANMATE SOFTWARE 
The installer program is capable of updating previous versions of the Scanmate software to the 
current version.  
 
IF the previous version of software utilized a SQLITE DATABASE, follow the Client PC instructions 
(above) to perform the update. No additional configuration will be required. After update, 
double-click the desktop icon to start the software. 
 
IF the previous version of software utilized a SQL SERVER DATABASE, an update to the database 
will be required before updating the software. Proceed to Page 14 for Updating SQL Server 
Database instructions. 



 

 7 SINGLE PC INSTALLATION: SQLITE DATABASE 
 

ATTENTION: The only PC that can access a SQLite database is the PC that is storing the SQLite 
database. The SQLite database cannot be made available on a network. 

ATTENTION: It is not suggested to use a SQLite database when saving large video files. 
 
A prompt will be displayed to remove DGH USB 
devices. This DOES NOT include the USB stick 
containing the installation program. 

Remove devices if needed and click the [INSTALL] 
button. 

 
 
 
 
 
 
 
During installation, a progress bar will appear in 
the installation dialog box.  SQLite and any 
additional prerequisites will be installed. 
Microsoft Windows may require approval to 
install components of the software. Select to 
allow the installation when prompts occur. 
 

When the installation has finished, the installer 
will display a statement that installation was 
successful. Click [FINISH] to exit the installer.  
 
 

Proceed to Page 11 for SQLite Configuration information. 



 

 8 SINGLE PC INSTALLATION: SQL SERVER DATABASE 
It is necessary to create a system administrator 
(sa) password when installing SQL Server. The 
password must be 8 characters long and contain 
at least one of each of the following: 

 - uppercase letter 
 - lowercase letter 
 - number 
 - symbol 
 
Be sure to save the password in a secure place.  
The space below has been provided for recording 
the password. 

Username: sa 

Password: _____________________________ 

 
Click [NEXT] to continue the installer. 
 
 
 

A prompt will be displayed to remove DGH USB 
devices. This DOES NOT include the USB stick 
containing the installation program. 

Remove devices if needed and click the [INSTALL] 
button. 

 
 
 
 
 

 
During installation, a progress bar will appear in 
the installation dialog box. The software and any 
additional prerequisites will be installed. 
Microsoft Windows may require approval to 
install components of the software. Select to 
allow the installation when prompts occur. 
 

When the installation has finished, the installer 
will display a statement that installation was 
successful.  Click [FINISH] to exit the installer.  
 

Proceed to Page 12 for SQL Server Configuration 
information. 



 

 9 SERVER PC INSTALLATION 
ATTENTION: All Server and Client PCs must be utilizing the same Windows Domain Network in 
order for the Client PCs to connect to the database. 
 

It is necessary to create a system administrator 
(sa) password when installing SQL Server. The 
password must be 8 characters long and contain 
at least one of each of the following: 

 - uppercase letter 
 - lowercase letter 
 - number 
 - symbol 
 
Be sure to save the password in a secure place.  
The space below has been provided for recording 
the password. 

Username: sa 

Password: _____________________________ 
 
Click [NEXT] to continue the installer. 
 
 
A prompt will be displayed to remove DGH USB 
devices. This DOES NOT include the USB stick 
containing the installation program. 

Remove devices if needed and click the [INSTALL] 
button. 

 
 
 
 
 
 
During installation, a progress bar will appear in 
the installation dialog box.  The software and any 
additional prerequisites will be installed. 
Microsoft Windows may require approval to 
install components of the software. Select to 
allow the installation when prompts occur. 
 
When the installation has finished, the installer 
will display a statement that installation was 
successful.  Click [FINISH] to exit the installer.  
 
After the Server PC installation has been 
completed, installation can be performed on the 
Client PCs.  

Proceed to Page 6 for Client PC information. 



 

 10 CLIENT PC INSTALLATION 
A prompt will be displayed to remove DGH USB 
devices. This DOES NOT include USB sticks 
containing the installation program.  

Remove devices if needed and click the [INSTALL] 
button. 

 

 

 

 

 

During installation, a progress bar will appear in 
the installation dialog box.  The software and any 
additional prerequisites will be installed. 
Microsoft Windows may require approval to 
install components of the software. Select to 
allow the installation when prompts occur. 
 
 
When the installation has finished, the installer 
will display a statement that installation was 
successful.  Click [FINISH] to exit the installer.  
 

Proceed to Page 12 for SQL Server Configuration 
information. 
 
 



 

 11 SQLITE CONFIGURATION 
Double click the DGH Scanmate desktop icon. The 
DGH Scanmate Configuration utility will run after 
a new install or update.  This configures how the 
Scanmate software will connect with the 
database. Click [START]. 
 

 

 

 

 
 
 
 
 

Check the radio button for SQLite. 

Enter a Username, Password and Password Hint 
in the fields provided.  This Username and 
Password is used to login to the DGH Scanmate 
program. It is strongly advised that the Username 
and Password be recorded and stored in a secure 
place. 

Click [NEXT] to continue configuration. 

 
Username: ______________________________  

Password: _______________________________  

 
 
 

The installer will prompt for confirmation that all 
credential information is correct. If all information 
is correct, click [NEXT].  

When configuration is complete, the application 
will display a message that the configuration was 
successful. Click the [CLOSE] button. 

 

Proceed to Page 15 for First Time Startup 
information. 



 

 12 SQL SERVER CONFIGURATION 
Double click the DGH Scanmate desktop icon. The 
DGH Scanmate Configuration utility will run after 
a new install or update.  This configures how the 
Scanmate software will connect with the 
database. Click [START]. 
 

 

 

 

 

 

 
Check the radio button for SQL Server. 

Click the [BROWSE] button. The SQL Server Name 
list will be updated with any instances of the DGH 
Server that are found. Select the instance of DGH 
Server. 
 

Enter the ‘sa’ Password created during the Server 
PC installation and click [CONNECT]. The status 
will be updated to “CONNECTED”. 

Once the status is “CONNECTED”, click the [NEXT] 
button. 

 

 
IF performing a FIRST TIME CONFIGURATION: 
 

A default database location is displayed in 
dropdown box. Click the [CREATE DB] button. 
Once the database is created, a message will be 
displayed stating that database creation was 
successful. Click the [NEXT] button. 

 

IF there is an EXISTING DATABASE: 
 

A message will be displayed that a current 
database is already installed. Click the [NEXT] 
button. 



 

 13  
IF an EXISTING DATABASE requires UPDATE: 
 

A message will be displayed that there is an 
unattached database. Click the [ATTACH DB] 
button. Once the database is attached and 
updated, a message will be displayed stating that 
database update was successful. Click the [NEXT] 
button. 
 
 

 
 

Enter a Username, Password and Password Hint 
in the fields provided. This Username and 
Password is used to login to the DGH Scanmate 
program. It is strongly advised that the Username 
and Password be recorded and stored in a secure 
place. 

Click [NEXT] to continue configuration. 

Username: ______________________________  

Password: _______________________________  

 
 

The installer will prompt for confirmation that all 
credential information is correct. If all 
information is correct, click [NEXT].  

 

When configuration is complete, the application 
will display a message that the configuration was 
successful. Click the [CLOSE] button. 

 

 

Proceed to Page 15 for First Time Startup 
information 



 

 14 UPDATING SQL SERVER DATABASE 
 

CAUTION: The database should be backed up before performing any update operation. 
Refer to Page 18 for SQL Server Database Backup instructions. 

 
On the PC that is hosting the database, start the 
installer and select the Server PC installation 
option. Click [NEXT] to continue. The installer 
may require administrator credentials to perform 
the update. If so, verify credentials as described 
below.  
 
 
VERIFY CREDENTIALS 
If administrator credentials are necessary, this 
dialog box will be displayed. Click [TEST 
CONNECTION]. 
 
 

IF the connection is OK, click the [NEXT] button. 
 
IF the connection fails, uncheck the Use 
Windows Authentication checkbox and enter 
the ‘sa’ password in the space provided. Test the 
connection again. One the connection is 
established, click the [NEXT] button. 
 
 
 

There is the option to modify the password if 
desired. Once the desired password is entered, 
click the [NEXT] button.  
 
 
Click the [INSTALL] button. 

 
During installation, a progress bar will appear in 
the installation dialog box.  The software and any 
additional prerequisites will be installed. 
Microsoft Windows may require approval to 
install components of the software. Select to 
allow the installation when prompts occur. 
 
 
 
When the installation has finished, the installer will display a statement that installation was 
successful.  Click [FINISH] to exit the installer.  
 
After the Server PC has been updated, updates can be performed on the Client PCs. Refer to 
Page 6 for Client PC information. 



 

 15 FIRST TIME STARTUP 
After the Scanmate installation and configuration has been completed, the Scanmate software 
can be used.  
 
Connect the USB cord of the device to an available USB port of the computer. The PC will 
recognize the device and perform additional driver installation. Typically this is initiated 
automatically and does not need to be performed by the user. Once the driver installation is 
complete, the Scanmate software is ready for use. 
 
Note: The PC will perform a driver installation for each USB port of the PC that a DGH product is 
connected to. Steps may vary depending on the version of the Windows Operating System being 
used.  
 
If the probe driver installation does not launch automatically, it is possible to initiate launch by 
pressing [WINDOWS KEY + R] on the keyboard to open the “Run” dialog box. Type hdwwiz into 
the available box and press the [ENTER] key on the keyboard. 

If given the option to use “Windows Update” to search for software, select “No” and click the 
[NEXT] button. Select the option to allow Windows to “Install the software automatically 
(recommended)”. Click [NEXT]. 
 
Operator manuals are available in the software by navigating to Help >> User Guides 



 

 16 SQLITE DATABASE BACK UP 
To prevent accidental data loss, it is recommended that backups be performed regularly and 
stored in a safe location. Preferably, backup files should not be stored on the same physical drive 
that hosts the database.  To backup the SQLite database: 
 
Open the Back Up / Restore window by selecting 
File > Database > Backup / Restore. 
 
The combo box shows the default location where 
the backup file will be created. If a different 
location is desired, click the […] button. A dialog 
window will open and allow a different location 
to be selected. 
 
Once the desired backup location is selected, click the [BACK UP] button. 
 
After the back up process has completed, a message box will display the location of the backup 
file. Click the [OK] button.  
 

 

SQLITE DATABASE RESTORE 
If it is necessary to restore a prior SQLite database, the back-up version can be reinstalled. Any 
records added since the date of the last back-up will be lost, so regular back-ups are essential. 
 
Open the Back Up / Restore window by selecting 
File > Database > Backup / Restore. 
 
The combo box shows the default location for 
backup files. If a different location is used for 
backup, click the […] button. A dialog window will 
open and allow a different location to be 
selected. 
 
Once the correct backup location is selected, click the [RESTORE] button. 
 

A message box will appear to warn you that the 
Restore Process will delete the current  database. 
Any data that was saved since the last back up 
will be lost. Select [YES] if you wish to continue. 
The Backup / Restore tool will attempt to restore 
the database from the backup file. 
 
 
After the restore process has completed, a message box will display which backup location the 
database was restored from. Click the [OK] button. 



 

 17 MANUALLY COPYING A SQLITE DATABASE 
Database backup can be performed by using the backup utility of the Scanmate software. Refer 
to Page 16 for SQLite Database Backup information. The database can also be copied manually 
for the purposes of backup or for transfer to a new PC.  
 
SQLite databases are single files and can be copied and pasted as other files are.  
 
Using Windows Explorer, navigate to the location of the SQLite database file. The location of the 
database file is C:\ProgramData\DGH Technology, Inc\DGH Scanmate\Data. 
 
Note: The ProgramData folder is a hidden folder by default on Windows systems. To make this 
folder visible,  go to Control Panel > Folder Options and under the View tab mark the radio 
button for “Show hidden files, folders, and drives”. 
 
Right-click on the database file DGH-Scanmate.db and 
select [COPY] from the menu.  
 
Using Windows Explorer, navigate to the location  where the database is to be copied to. Right-
click and select [PASTE] from the menu. 
 
 

MOVING A SQLITE DATABASE BETWEEN SYSTEMS 
The SQLite database is a single file and can be moved between systems by creating a copy 
(described in the Manually Copying a SQLite Database section above) and pasting the database 
file in the appropriate location of the destination PC.  
 
On the origin PC, using Windows Explorer, navigate to the location of the SQLite database file 
and create a copy. The location of the database file is C:\ProgramData\DGH Technology, 
Inc\DGH Scanmate\Data. 
 
Note: The ProgramData folder is a hidden folder by default on Windows systems. To make this 
folder visible,  go to Control Panel > Folder Options and under the View tab mark the radio 
button for “Show hidden files, folders, and drives”. 
 
Transfer the file to the destination PC. The file must be copied to the C:\ProgramData\DGH 
Technology, Inc\DGH Scanmate\Data folder in order for the Scanmate program to locate it. 
 
 



 

 18 SQL SERVER DATABASE BACKUP 
To prevent accidental data loss, it is recommended that backups be performed regularly and 
stored in a safe location. Preferably, backup files should not be stored on the same physical drive 
that hosts the database.  To backup the SQL Server database: 
 
Open the Back Up / Restore window by selecting 
File > Database > Backup / Restore. 
 
Connect to the DGH Database Server by entering 
the system administrator username and password 
and click the [CONNECT] button. 
 
Note: This is the same username and password  
created during SQL Server installation. 
 
 
Once a connection has been established with the 
database, a message will be displayed stating the 
software is connected to the server. Click the [OK] 
button. 
 
 
 
 
“DGH-Scanmate” will be displayed in the 
‘Database’ combo box and click the [BACK UP] 
button.  
 
 
 
 
 
 
 
A dialog box will be displayed. Select the desired 
backup location and click the [OK] button. 
Database backup will begin. A progress bar will 
display the backup status. 
 
 
Once the back up process has completed, a 
message box will state that the backup has been 
completed, and will display the location of the 
backup file.  Click the [OK] button. 
 
 
 



 

 19 SQL SERVER DATABASE RESTORE 
If it is necessary to restore a prior database, the back-up version can be reinstalled. Any records 
added since the date of the last back-up will be lost, so regular back-ups are essential. 
 
Open the Back Up / Restore window by selecting 
File > Database > Backup / Restore. 
 
Connect to the DGH Database Server by entering 
the system administrator username and password 
and click the [CONNECT] button. 
 
Note: This is the same username and password  
created during SQL Server installation. 
 
Once a connection has been established with the 
database, a message will be displayed stating the 
software is connected to the server. Click the [OK] 
button. 
 
 
 
“DGH-Scanmate” will be displayed in the 
‘Database’ combo box and click the [RESTORE] 
button.  
 
 
 
 
 
 
 
 
 
A dialog box will be displayed. Select the desired 
backup location and click the [OK] button.  
 
A message box will appear to warn you that the 
Restore Process will delete the current  database. 
Any data that was saved since the last back up will 
be lost. Select [YES] if you wish to continue.  
The Backup / Restore tool will attempt to restore 
the database from the backup file. 
 
 
 
Once the restore process has completed, a 
message box will display which backup location 
the database was restored from.  Click the [OK] 
button.  



 

 20 MANUALLY CONFIGURE FIREWALL PORTS  
Note: Firewall configuration will be performed automatically during Server PC installation if the 
‘Configure Windows Firewall’ checkbox is marked.  
 

Note: Opening ports in your firewall may make your computer less secure and increase the risk 
of it being exploited by malicious software.  

 
When a database is accessed over a network, the firewall of the computer hosting the database 
must be configured to allow access to SQL Server. Client computers will be unable to connect to 
the database unless this is done. If preferred, firewall settings may be configured manually by 
following the steps below. 
 
On the Start menu of the computer/server hosting the 
database, click Run, type WF.msc, and then click [OK]. 
 
Left-Click on Inbound Rules to highlight it, then right-click 
on Inbound Rules and select ‘New Rule’. 
 
 
In the window that opens, select the PORT radio button 
and then click [NEXT] 
 
 
 

Select the “TCP” and “Specific Local Ports” radio buttons. 
Enter port number 1433 then click [NEXT]. 
  
 
 
 
 
 
 

Select “Allow the connection” and then click 
[NEXT]. 
 
 
 
 
 
Mark the checkbox for the network profiles where 
you want this rule to apply and then click [NEXT]. 
 
 
Enter a name for this Rule and then click [FINISH]. 
 
 
A UDP port must also be configured for the firewall. To do this, follow the steps above, however 
during step 4, select UDP (instead of TCP), and enter 1434 (instead of 1433). 
 
 
Once the firewall is configured, the database server must be configured to use the new ports. 
Refer to Page 21 for Manually Configuring SQL Server Firewall Settings information. 



 

 21 MANUALLY CONFIGURE SQL SERVER FIREWALL SETTINGS 
Note: Firewall configuration will be performed automatically during Server PC installation if the 
‘Configure Windows Firewall’ checkbox is marked.  
 

First the firewall of the computer hosting the database must be configured (see Page 20, 
Manually Configure Firewall Ports), then SQL Server must be configured to correctly use those 
ports. If preferred, SQL Server firewall settings may be configured manually by following the 
steps below. 
 
Launch SQL Server Configuration Manager by going to the Start menu and selecting Microsoft 
SQL Server 2012 > Configuration Tools > SQL Server 
Configuration Manager. 
 

In the left-hand panel go to SQL Server Configuration 
Manager (Local) > SQL Server Network Configuration > 
Protocols for DGHSERVER. This will change the items 
displayed on the right-hand side. 
 
 
In the right-hand panel, right-click on TCP/IP and  select 
‘Properties’. 
 
 
 
 
Select the ‘IP Addresses Tab’ at the top of the menu and 
scroll down to IPAll section. 
 
Delete the “0” from TCP Dynamic Ports field (so it is left 
blank) and enter “1433” in the TCP Port field. 
 
Click [OK] to complete the change. A pop-up message 
will instruct you that SQL server must be restarted for 
the changes to apply. Click [OK]. 
 
 
 
 
 
 

In the left-hand panel, left-click on  SQL Server Services. 
This will change the items displayed on the right-hand 
side. 
 
 
 
 
 
In the right-hand panel, right-click on  
SQL Server (DGHServer) and select ‘Restart’.   



 

 22 MANUALLY COPYING A SQL SERVER DATABASE 
ATTENTION: To manually copy a SQL Server Database, the SQL Server Management Studio 
software must be installed. The software is not installed by default, but is available on the 
installation media. 
 

ATTENTION:  This should only be performed when the database is not being actively used. All 
active users will be disconnected from the database. 
 
Database backup can be performed by using the backup utility of the Scanmate software. Refer 
to Page 18 for SQL Server Database Backup information. The database can also be copied 
manually for the purposes of backup or for transfer to a new location.  
 
Launch SQL Server Management Studio on the computer hosting the database.  Management 
Studio can be found from the Windows Start Menu by selecting Programs > Microsoft SQL 
Server 2012 > SQL Server Management Studio.  
 
Connect to DGH Server by changing the authentication to “SQL Server Authentication” and then 
enter the system administrator username (sa) and password that was created when performing 
the Server PC installation. Click the [CONNECT] button 
 
Note: This is the “sa” username and password that were created during Server PC installation. 
 
 
Stop the database by right-clicking on the 
DGHServer and selecting “Stop” from the drop-
down menu. 
 
Using Windows Explorer, navigate to the data 
directory of the program. This is found at: 
C:\Program Files\DGH Technology, Inc. of the 
computer hosting the database. 
 
Copy the “Data” folder found in this directory and 
paste it in the desired location. For back-up 
purposes, this folder can be stored anywhere, 
though preferably on a separate physical drive.  
 
 
To restart the database, right-click on DGHServer and selecting “Start” from the drop-down 
menu. 
 
If you plan to transfer the database for use on a different computer, refer to Page 23 for 
Attaching A SQL Server Database information.  
 
 



 

 23 ATTACHING A SQL SERVER DATABASE 
ATTENTION: To manually copy a SQL Server Database, the SQL Server Management Studio 
software must be installed. The software is not installed by default, but is available on the 
installation media. 
 
 
If database files have been manually copied and moved to a new PC or drive, the files must be re
-attached to the DGH-Server in order to be accessed by the Scanmate software. The destination 
PC must have SQL Server 2012 installed prior to performing this procedure (refer to Page 6 for 
Server PC information). 
 
Paste the database files to default location C:\Program Files\DGH Technology Inc\Data\DGH 
Scanmate, otherwise they will not be identified by the software. 
 
 
Launch SQL Server Management Studio on the computer hosting the database.  Management 
Studio can be found from the Windows Start Menu by selecting Programs > Microsoft SQL 
Server 2012 > SQL Server Management Studio.  
 
Connect to DGH Server by changing the authentication to “SQL Server Authentication” and then 
enter the system administrator username (sa) and password that was created when the DGH 
Database Server was installed. Click the 
[CONNECT] button 
 
NOTE: This is the “sa” username and password 
that were created during Server PC installation. 
 
 
 
Under the DGHServer, right click on “Databases” 
Folder and select Attach. 
 
The “Attach Databases” dialog window will open.  
Click the [ADD] button 
 
 
The “Locate Database Files” dialog window will open. Browse to the .mdf file for the DGH-
Scanmate database that you wish to use.   
 
 
Note: The .mdf file default location is C:\Program Files\DGH Technology Inc\Data\DGH 
Scanmate. If you have created a copy of the database (as described in the previous section) 
the .mdf file is located in the “Data” folder. 
 
Select the .mdf file and click the [OK] button. The “Attach Databases” dialog window will now 
show the DGH-Scanmate.mdf  Click [OK]. 



 

 24 MOVING A SQL SERVER DATABASE LOCALLY 
The Scanmate application is capable of moving the database to other local disks on the same PC. 
This may be necessary if a physical drive is nearing capacity. 
 
From the top Scanmate menu select Preferences > System then click the [CHANGE 
CONFIGURATION] button in the System Preferences menu. Click the [START] button when the 
splash screen is displayed. 
 
Check the radio button for SQL Server. 
 
Click the [BROWSE] button. The SQL Server Name 
list will be updated with any instances of the DGH 
Server found on the network. Select the instance 
of DGH Server. 
 
Enter the ‘sa’ Password created during the Server 
PC installation and click [CONNECT]. The status 
will be updated to “CONNECTED”. 
 
Once the status is “CONNECTED”, click the [NEXT] 
button. 
 
 
 

The next screen will show a combo box with the 
current database location. Click on the combo 
box to expand it. Other potential database 
locations will be listed. 
 
Click on the desired location and then click the 
[MOVE DB] button. 
 
When the database is moved a message will be 
displayed stating the move was successful. Click 
the [NEXT] button. 
 
 
 

After the database is moved, the installer will give 
the option to change the username and 
password. Changes may be made if desired, but 
are not necessary. Click the [NEXT] button. 
 
The installer will prompt for confirmation that all 
credential information is correct. If all 
information is correct, click [NEXT]. 
 
When configuration is complete, the application 
will display a message that the configuration was 
successful. Click the [CLOSE] button. 



 

 25 MOVING A SQL SERVER DATABASE BETWEEN SYSTEMS 
The Scanmate application offers a Backup / Restore utility that can be used to move a database 
from an origin server to a destination server. 
 
Perform a backup of the original database per Page 18, SQL Server Database Backup. The 
backup will be a single file. Copy this file to electronic media for transfer from the origin server 
to a destination server. 
 
On the destination server, perform the Server PC installation (starting on Page 6).  
 
Perform Client PC installations (starting on Page 6) on any Client PCs that will be connected to 
the destination server.  
 
On a Client PC that is networked to the destination server, perform a database restore as per the 
SQL Server Database Restore section of this document (Page 19).  



 

 26 DELETING A SQLITE DATABASE  
The SQLite database can be deleted by using Windows Explorer to navigate to the location of the  
database file (C:\ProgramData\DGH Technology, Inc\DGH Scanmate\Data), then right-clicking 
on the DGH-Scanmate.db file and selecting [DELETE] from the menu. 

 
WARNING: Ensure that the database has been successfully moved or backed-up before 
deleting.  Deleting the database without backing-up will result in permanent data loss. 

 
 
 
DELETING A SQL SERVER DATABASE 
The following steps describe how to permanently delete the DGH Scanmate database.  
 

WARNING: Ensure that the database has been successfully moved or backed-up before 
deleting.  Deleting the database without backing-up will result in permanent data loss. 
 

Launch SQL Server Management Studio on the 
computer hosting the database.  Management 
Studio can be found from the Windows Start 
Menu by selecting Programs > Microsoft SQL 
Server 2012 > SQL Server Management Studio. It 
can also be started by pressing [WINDOWS KEY + 
R] on the keyboard to open the “Run” dialog box 
and typing in ssms.exe into the box and clicking 
the [ENTER] key. 
 
Connect to DGHServer by entering the system 
administrator username and password that was 
created when the DGH Database Server was 
installed. 
 
Note: This is the “sa” username and password 
that were created during Server PC installation. 
 
 
Under the DGHServer, expand the “Databases” 
Folder. Right-click on the DGH-Scanmate entry 
and select “Delete”. 
 



 

 27 TROUBLESHOOTING GUIDE 

INSTALL ERROR—SQL SERVER 

- The user installing SQL Server must have full administrative privileges for correct installation. 

- If SQL Server was previously installed on the computer, the computer must be restarted before  
 SQL Server can be reinstalled. 

- SQL Server installation may fail if a “Strong” password isn’t used. Make sure the system administrator 
 password uses a mixture of capital and lowercase letters, numbers and symbols and is at least 8 
 characters long (!DGHTest1 is an example of a strong password). 

- The PC user login name must be different than the PC system name. 

UNABLE TO CONNECT—DGH DATABASE SERVER 

-- Confirm that the location (computer name) and password for connecting to the database server 
 are correct. 

- If connecting to a database over the network, verify that the computer hosting the  database  
 is powered ON and that all network cables are connected. Verify that the firewall on the database host  
 computer is configured to allow access to SQL Server (see MANUALLY CONFIGURE FIREWALL PORTS 
 and MANUALLY CONFIGURE SQL SERVER FIREWALL SETTINGS sections).  

- Verify that both computers are utilizing the same WINDOWS DOMAIN NETWORK. 

- Confirm that the “SQL Server (DGHSERVER)” instance is running in SQL Server 2012. 

 1. Launch SQL Server Configuration Manager on the computer hosting the database. Configuration 
  Manager can be found in the Windows Start Menu by selecting Programs > Microsoft SQL Server 
  2012  > Configuration Tools >  SQL Server Configuration Manager. 

 2. In the SQL Server Configuration Manager’s left-hand column select SQL Server Configuration 
  Manager > SQL Server Services. 

 3. The software will populate a list in the right-hand column. Confirm that the item labelled  
  SQL Server (DGHSERVER) state is “Running”. If this item is listed as “Stopped”, right-click and 
  select “Start” from the drop-down menu. 

 

- If the system administrator password for SQL Server has been lost or forgotten, it will be 
 necessary to reset it using Management Studio. The following steps must be performed by a user that 
 has full administrator access to the PC. 

 1. Launch SQL Server Management Studio on the computer hosting the database.   
  Management Studio can be found from the Windows Start Menu by selecting  
  Programs > Microsoft SQL Server 2012 > SQL Server Management Studio.  

 2. Select “Windows Authentication” instead of “SQL Server Authentication”. 

 3. Navigate to Security > Logins and right-click on the “sa” User Account, then select  
  Properties. 

 4. Enter and confirm a new password for the sa account. 
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UNABLE TO CONNECT—DGH SCANMATE DATABASE 

- Confirm that the location, user name and password for connecting to the database are correct. 

- If the database was moved, or SQL Server was reinstalled, you will need to reattach the DGH-Scanmate 
 database to the DGH Database server.  

- If connecting to a database over the network, verify that the computer hosting the  database 
 is powered ON and the firewall on the computer hosting the database has been configured to allow 
 access to SQL Server (see the MANUALLY CONFIGURE FIREWALL PORTS  and MANUALLY CONFIGURE 
 SQL SERVER FIREWALL SETTINGS sections).  

- Verify that both computers are utilizing the same WINDOWS DOMAIN NETWORK. 

INSTALL ERROR—.NET FRAMEWORK ON WINDOWS SBS SERVER 2008 

To install the .NET framework on Windows SBS Server 2008, follow the steps below:  

1. On the Start Menu select: Start > Administrative Tools > Server Manager. 

2. Click on "Features" in the left panel of the Server Manager dialog box. 

3. Click on "Add Features" in the Features panel of the Server Manager dialog box. 

4. Expand the ".NET Framework 3.5.1 Features" in the Select Features dialog box. 

5. In the expanded ".NET Framework 3.5.1 Features" list, check ONLY ".NET Framework 3.5.1" and click 
the Next button. 

6. Click the Install button on the "Confirm Installation Selections" dialog box. 

7 When the "Installation Results" dialog box appears, click the Close button. 

USB CONNECTION NOT DETECTED 

- Confirm that the drivers have been installed for the USB 2.0 port the module is currently 

 connected to.  

-  Confirm that the USB cable is fully inserted and firmly  seated in the USB interface module/probe. 

- Connect the USB Interface Module to other USB ports on the PC. Confirm that the USB cable is fully 

 inserted and firmly seated in the USB connector on the PC. 

PROBE KEY EXPIRED 

-  The USB Interface Module must be connected to the PC running the Scanmate application after 

 every 20 hours of use. 

- If connecting the USB Interface Module does not reset the Probe Key, try the steps  described in “USB 

 Connection Not Detected” section above.  

 

NEW PROBE KEY REQUIRED 

- If the software displays the message “Enter the key for the given probe and then press save” upon 

 startup, contact DGH Technology Inc. to request a new probe key number. 


